aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2004-03-22 23:50:43 +0000
committerGuy Harris <guy@alum.mit.edu>2004-03-22 23:50:43 +0000
commit65736157b451b1990b4a38f4014d78c09f5c6e31 (patch)
tree3fb2d84c125491bc6b8887e3782b02380d432c4b
parent41c5ac682154ac18b18dffb454f95938fe24023d (diff)
To build with GLib 2.x/GTK+ 2.x, you need to configure with
--enable-gtk2 regardless of whether you have GLib 1.2[.x]/GTK+ 1.2[.x] installed or not. svn path=/trunk/; revision=10444
-rw-r--r--README.macos12
1 files changed, 9 insertions, 3 deletions
diff --git a/README.macos b/README.macos
index 04d51c5246..5bb5916f69 100644
--- a/README.macos
+++ b/README.macos
@@ -1,4 +1,4 @@
-$Id: README.macos,v 1.5 2004/03/22 23:40:44 guy Exp $
+$Id: README.macos,v 1.6 2004/03/22 23:50:43 guy Exp $
This file tries to help building Ethereal for Mac OS X (Ethereal does
not work on earlier versions of Mac OS).
@@ -48,8 +48,14 @@ do "sudo ranlib /usr/lib/libjpeg.a" after "make install-lib".
For libpng, use scripts/makefile.darwin, not scripts/makefile.macosx.
-In case you also have gtk1 installed, you will need to run configure
-with the "--enable-gtk2" argument.
+You will need to run Ethereal's configure script with the
+"--enable-gtk2" argument - by default, it'll try to configure with GLib
+1.2[.x] and GTK+ 1.2[.x], in which case:
+
+ if they're not installed, the configure script will fail;
+
+ if they are installed, the configure script will configure
+ Ethereal to build with them.
Another problem are compile errors in the wiretap directory like the
following: