aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-07-12 23:28:57 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-07-13 00:09:56 +0200
commitb259b722003c3a20770122f06f5e9eec1e637a16 (patch)
tree46051959316fe68f1a413e7811f97a10e72226c7
parent217780835875553b11d4e38fa36e66c7a898d0a3 (diff)
host: Use the pkg-config to find libosmocore headers and libs
-rw-r--r--host/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/host/Makefile b/host/Makefile
index 819aa26..4f117b1 100644
--- a/host/Makefile
+++ b/host/Makefile
@@ -1,4 +1,4 @@
-LDFLAGS=-lusb -losmocore
+LDFLAGS=-lusb `pkg-config --libs libosmocore` -losmocore
all: simtrace
@@ -6,7 +6,7 @@ simtrace: main.o usb_helper.o usb.o apdu_split.o
$(CC) $(LDFLAGS) -o $@ $^
%.o: %.c
- $(CC) $(CFLAGS) -o $@ -c $^
+ $(CC) $(CFLAGS) `pkg-config --cflags libosmocore` -o $@ -c $^
clean: