aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a1f695f..ae59bd6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,21 @@ AUTOMAKE_OPTIONS = gnu
bin_PROGRAMS = sam7
-sam7_SOURCES = main.c io.c io_@IOTYPE@.c samba.c cmd.c
+sam7_SOURCES = main.c io.c samba.c cmd.c
+
+if HAVE_IOKIT
+sam7_SOURCES += io_iokit.c
+endif
+if HAVE_WIN32
+sam7_SOURCES += io_win32.c
+endif
+if HAVE_POSIX
+sam7_SOURCES += io_posix.c
+endif
+if HAVE_LIBUSB
+sam7_SOURCES += io_libusb.c
+endif
+
noinst_HEADERS = io.h samba.h cmd.h loader128_data.h loader256_data.h
EXTRA_DIST = driver/Makefile driver/at91.c \