aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-07-04 15:57:04 -0700
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-07-08 16:51:35 +0200
commit432e5a6c2f5e453b7dcafecb7c9ff816029345a6 (patch)
tree52c4cde49e28780be47bf852ef9f45f6a459fe0b /Makefile.am
parent201a024b67c44477225a94c6e0ce99df5c8c8134 (diff)
build: update autotools to modern standards.
This includes removing AC_CANONICAL_BUILD/AC_CANONICAL_TARGET (weren't used), renaming configure.in to configure.ac (required for automake 1.13 coming up), moving automake options to configure.ac (removes use of AM_INIT_AUTOMAKE with two parameters, which is also gone with automake 1.13). Also remove empty files and declare the system foreign, not gnu (NEWS and AUTHORS are not used), avoid re-declaring in the distributed files the conditional sources (automake takes care of that), and don't use -Werror (as it would fail to build with GCC 4.6 and 4.7). Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index ae59bd6..7d6aaf8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,4 @@
-AM_CFLAGS = -Wall -Werror
-
-AUTOMAKE_OPTIONS = gnu
+AM_CFLAGS = -Wall
bin_PROGRAMS = sam7
@@ -22,6 +20,5 @@ endif
noinst_HEADERS = io.h samba.h cmd.h loader128_data.h loader256_data.h
EXTRA_DIST = driver/Makefile driver/at91.c \
- io_win32.c io_posix.c io_iokit.c io_libusb.c\
loader/Makefile loader/at91.h loader/bin2c.c loader/crt0.S \
- loader/loader.c loader/loader.lds \ No newline at end of file
+ loader/loader.c loader/loader.lds