aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2012-03-27 20:53:49 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2012-03-27 20:53:49 +0200
commit001bfb96ef410c24927d04d6b294fe0a2aab4623 (patch)
tree1a920a5e775dbf3df37d77cbf56885491e4efe8c /src/Makefile.am
parent37bb5ca0693d1eff6772db8a9ac0e19d93523dc9 (diff)
add autotools based build system
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..4313876
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,15 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
+LIBVERSION=0:0:0
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -fPIC -Wall
+
+lib_LTLIBRARIES = librtlsdr.la
+
+librtlsdr_la_SOURCES = rtl-sdr.c tuner_e4000.c tuner_fc0013.c
+librtlsdr_la_LDFALGS = -version-info $(LIBVERSION)
+
+bin_PROGRAMS = rtl_sdr
+rtl_sdr_SOURCES = main.c
+rtl_sdr_LDADD = librtlsdr.la