aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-11-16 22:48:33 +0100
committerHarald Welte <laforge@gnumonks.org>2016-11-17 21:09:55 +0100
commit68fc12775fac03e5e26a008dfa68c92498bfb772 (patch)
treea14f73f0bb16bde00828bfba2911ebeeafb0e68f /src/Makefile.am
parent5d93f0f4eceda7bef29e27e6ec521c1e56640c25 (diff)
Install the pcuif_proto.h header file
So far, we used to keep a copy of the header file around in both osmo-pcu and osmo-bts projects. Before we start introducing a third copy in openbsc, let's have the osmo-pcu install the header file and make the other programs use that. Change-Id: I60976c9be5488256d1ff55fdc5aa548e3705400d
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9b047e7..7cc239b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,7 +19,7 @@
#
AUTOMAKE_OPTIONS = subdir-objects
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGB_CFLAGS) $(LIBOSMOGSM_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/include $(STD_DEFINES_AND_INCLUDES) $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGB_CFLAGS) $(LIBOSMOGSM_CFLAGS)
if ENABLE_SYSMODSP
AM_CPPFLAGS += -DENABLE_DIRECT_PHY
@@ -78,7 +78,6 @@ noinst_HEADERS = \
gprs_rlcmac.h \
gprs_ms.h \
gprs_ms_storage.h \
- pcuif_proto.h \
pcu_l1_if.h \
gsm_timer.h \
bitvector.h \
@@ -98,6 +97,9 @@ noinst_HEADERS = \
gprs_coding_scheme.h \
egprs_rlc_compression.h
+nobase_include_HEADERS =
+ osmocom/pcu/pcuif_proto.h
+
osmo_pcu_SOURCES = pcu_main.cpp
if ENABLE_SYSMODSP