aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-12-06 15:51:46 +0100
committerOliver Smith <osmith@sysmocom.de>2019-12-06 16:06:38 +0100
commitb0ba927e337987bb78f318f1866b08c98f1b91ed (patch)
tree3ea5cdae9ac9b6c82736274fa95321a5b36bc0ef /debian/rules
parentfb1dc7c405f6114687338382149bfc775597935a (diff)
Revert "Drop python2 support"
This reverts commit fb1dc7c405f6114687338382149bfc775597935a. I was under the impression, that all previous scripts were already working with python 3. But as it turns out, this isn't true. Reverting, so I can properly post follow-up patches, that fix the issues before we apply this "drop python2" patch again. Related: OS#2819 Change-Id: Ic1559d1a9f7839fa86a841d62a04b22e1caed466
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d0817c3..04b59f6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,13 @@
#!/usr/bin/make -f
%:
- dh $@ --with python3
+ dh $@ --with python2,python3
override_dh_auto_install:
+ python2 setup.py install --install-layout=deb --root=$(CURDIR)/debian/python2-osmopy-libs
+ rm -rf $(CURDIR)/debian/python2-osmopy-libs/usr/bin
+ python2 setup.py install --install-layout=deb --root=$(CURDIR)/debian/python2-osmopy-utils
+ rm -rf $(CURDIR)/debian/python2-osmopy-utils/usr/lib
python3 setup.py install --install-layout=deb --root=$(CURDIR)/debian/python3-osmopy-libs
rm -rf $(CURDIR)/debian/python3-osmopy-libs/usr/bin
python3 setup.py install --install-layout=deb --root=$(CURDIR)/debian/python3-osmopy-utils