aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2022-07-31 15:51:19 +0200
committerHarald Welte <laforge@osmocom.org>2022-08-12 12:46:05 +0200
commit63054b0d3681c4218e8305fc8c0f01efebe8e018 (patch)
tree0366c436502ef615316ed07a9551ab3929781346 /setup.py
parentcab26c728c0544db398ab0d1ba78d123bf134c30 (diff)
Add new pySim.ota library, implement SIM OTA crypto
This introduces a hierarchy of classes implementing * ETS TS 102 225 (general command structure) * 3GPP TS 31.115 (dialects for SMS-PP) In this initial patch only the SMS "dialect" is supported, but it is foreseen that USSD/SMSCB/HTTPS dialects can be added at a later point. Change-Id: I193ff4712c8503279c017b4b1324f0c3d38b9f84
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ec1a76a..d73e67e 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,8 @@ setup(
"bidict",
"gsm0338",
"termcolor",
- "colorlog"
+ "colorlog",
+ "pycryptodome"
],
scripts=[
'pySim-prog.py',