summaryrefslogtreecommitdiffstats
path: root/src/shared/libosmocore/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/shared/libosmocore/configure.in')
-rw-r--r--src/shared/libosmocore/configure.in31
1 files changed, 27 insertions, 4 deletions
diff --git a/src/shared/libosmocore/configure.in b/src/shared/libosmocore/configure.in
index e3e178c0..c3e00610 100644
--- a/src/shared/libosmocore/configure.in
+++ b/src/shared/libosmocore/configure.in
@@ -35,25 +35,48 @@ dnl Generate the output
AM_CONFIG_HEADER(config.h)
AC_ARG_ENABLE(talloc,
- [ --disable-talloc Disable building talloc memory allocator ],
+ [AS_HELP_STRING(
+ [--disable-talloc],
+ [Disable building talloc memory allocator]
+ )],
[enable_talloc=0], [enable_talloc=1])
AM_CONDITIONAL(ENABLE_TALLOC, test "x$enable_talloc" = "x1")
AC_ARG_ENABLE(plugin,
- [ --disable-plugin Disable support for dlopen plugins ],
+ [AS_HELP_STRING(
+ [--disable-plugin],
+ [Disable support for dlopen plugins],
+ )],
[enable_plugin=0], [enable_plugin=1])
AM_CONDITIONAL(ENABLE_PLUGIN, test "x$enable_plugin" = "x1")
AC_ARG_ENABLE(tests,
- [ --disable-tests Disable building test programs ],
+ [AS_HELP_STRING(
+ [--disable-tests],
+ [Disable building test programs]
+ )],
[enable_tests=0], [enable_tests=1])
AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "x1")
AC_ARG_ENABLE(vty,
- [ --disable-vty Disable building VTY telnet interface ],
+ [AS_HELP_STRING(
+ [--disable-vty],
+ [Disable building VTY telnet interface]
+ )],
[enable_vty=0], [enable_vty=1])
AM_CONDITIONAL(ENABLE_VTY, test "x$enable_vty" = "x1")
+AC_ARG_ENABLE(panic_infloop,
+ [AS_HELP_STRING(
+ [--enable-panic-infloop],
+ [Trigger infinite loop on panic rather than fprintf/abort]
+ )],
+ [panic_infloop=1], [panic_infloop=0])
+if test "x$panic_infloop" = "x1"
+then
+ AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])
+fi
+
AC_OUTPUT(
libosmocore.pc