summaryrefslogtreecommitdiffstats
path: root/src/shared/libosmocore/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-09-08 20:44:55 +0200
committerHarald Welte <laforge@gnumonks.org>2012-09-08 20:45:44 +0200
commitd08b949c2b0e41a46bfbe984766601f73e53697d (patch)
treefb3f3c4f8cb6ca60167ae98aa024a4dbb385d361 /src/shared/libosmocore/src/gsm/Makefile.am
parent24df176826b3c7b445c34c5a6ae106d0892c9052 (diff)
parent972b502ecaf3b919b7e89c13257dd6ec97aaafb7 (diff)
Merge libosmocore commit '972b502ecaf3b919b7e89c13257dd6ec97aaafb7' into master
this updates libosmocore to the current libosmocore.git master, mainly to import the msgb_get() / msgb_pull() fixes.
Diffstat (limited to 'src/shared/libosmocore/src/gsm/Makefile.am')
-rw-r--r--src/shared/libosmocore/src/gsm/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/shared/libosmocore/src/gsm/Makefile.am b/src/shared/libosmocore/src/gsm/Makefile.am
index 46d40a11..b72a8d43 100644
--- a/src/shared/libosmocore/src/gsm/Makefile.am
+++ b/src/shared/libosmocore/src/gsm/Makefile.am
@@ -1,9 +1,9 @@
# This is _NOT_ the library release version, it's an API version.
# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
-LIBVERSION=2:0:1
+LIBVERSION=3:0:0
INCLUDES = $(all_includes) -I$(top_srcdir)/include
-AM_CFLAGS = -fPIC -Wall
+AM_CFLAGS = -Wall ${GCC_FVISIBILITY_HIDDEN}
# FIXME: this should eventually go into a milenage/Makefile.am
noinst_HEADERS = milenage/aes.h milenage/aes_i.h milenage/aes_wrap.h \
@@ -19,7 +19,9 @@ libosmogsm_la_SOURCES = a5.c rxlev_stat.c tlv_parser.c comp128.c gsm_utils.c \
lapd_core.c lapdm.c \
auth_core.c auth_comp128v1.c auth_milenage.c \
milenage/aes-encblock.c milenage/aes-internal.c \
- milenage/aes-internal-enc.c milenage/milenage.c
+ milenage/aes-internal-enc.c milenage/milenage.c gan.c
-libosmogsm_la_LDFLAGS = -version-info $(LIBVERSION)
+libosmogsm_la_LDFLAGS = -Wl,--version-script=$(srcdir)/libosmogsm.map -version-info $(LIBVERSION)
libosmogsm_la_LIBADD = $(top_builddir)/src/libosmocore.la
+
+EXTRA_DIST = libosmogsm.map