summaryrefslogtreecommitdiffstats
path: root/src/host/layer23/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-04-05 19:26:09 +0800
committerHarald Welte <laforge@gnumonks.org>2010-04-05 21:30:00 +0800
commitdb60b706ccef02a9b1ef28facc6b3d6f94da9e36 (patch)
tree8fd0439abac4242580f99792e04cf39f837c0896 /src/host/layer23/src/Makefile.am
parentfb8dfadc6639cf4174dd69119e8ed9661b0625bc (diff)
layer23: split into liblayer23 and 'apps'
similar to the concept of having 'apps' in the firmware build process, I'm now building the common code as liblayer23 and we have three apps that use this library: layer23 - the old layer23 program bcch_scan - a passive bcch scanner under development echo_test - a test program sending large msgb's containing zero bytes
Diffstat (limited to 'src/host/layer23/src/Makefile.am')
-rw-r--r--src/host/layer23/src/Makefile.am19
1 files changed, 15 insertions, 4 deletions
diff --git a/src/host/layer23/src/Makefile.am b/src/host/layer23/src/Makefile.am
index ae867faf..0840ef03 100644
--- a/src/host/layer23/src/Makefile.am
+++ b/src/host/layer23/src/Makefile.am
@@ -1,7 +1,18 @@
INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS)
-sbin_PROGRAMS = layer23
-layer23_SOURCES = main.c l1ctl.c gsmtap_util.c lapdm.c rslms.c \
- layer3.c logging.c
-layer23_LDADD = $(LIBOSMOCORE_LIBS)
+noinst_LIBRARIES = liblayer23.a
+liblayer23_a_SOURCES = l1ctl.c gsmtap_util.c lapdm.c rslms.c \
+ layer3.c logging.c
+
+bin_PROGRAMS = bcch_scan layer23 echo_test
+
+bcch_scan_SOURCES = main.c app_bcch_scan.c
+bcch_scan_LDADD = liblayer23.a
+
+layer23_SOURCES = main.c app_phone.c
+layer23_LDADD = liblayer23.a
+
+echo_test_SOURCES = main.c app_echo_test.c
+echo_test_LDADD = liblayer23.a