summaryrefslogtreecommitdiffstats
path: root/src/host/gprsdecode/Makefile.am
diff options
context:
space:
mode:
authorLuca Melette <luca@srlabs.de>2018-01-22 17:14:08 +0100
committerVadim Yanitskiy <axilirator@gmail.com>2018-02-06 14:05:17 +0700
commite357646ed708bd5acc56b250d01bd695fff9cd73 (patch)
treee5de1a50a54fff4f97428b3d5473f35c11350309 /src/host/gprsdecode/Makefile.am
parent9fa291dd2ba880be0a07c0c3fff1ce537bbee4d1 (diff)
Import gprsdecode utility from SRLabs
This change introduces a modified version of gprsdecode utility, which is intended to decode the GPRS burst captures and forward decoded packets to the GSMTAP sink. The following modifications were made: - use shared libosmocoding library for GSM 05.03 coding; - use optget for command line options parsing; - use a single application select loop; - use GNU automake as the build system; - add regression tests (GNU autotest); - clean up and comment the code; - add license headers; The code is based on work of SRLabs: https://srlabs.de/ git://git.srlabs.de/gprsdecode.git Related: OS#1672 Change-Id: I12234d37c66b83b8abd60f7511fa1d7837db1856
Diffstat (limited to 'src/host/gprsdecode/Makefile.am')
-rw-r--r--src/host/gprsdecode/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/host/gprsdecode/Makefile.am b/src/host/gprsdecode/Makefile.am
new file mode 100644
index 00000000..542d54b6
--- /dev/null
+++ b/src/host/gprsdecode/Makefile.am
@@ -0,0 +1,36 @@
+AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
+SUBDIRS = tests
+
+AM_CPPFLAGS = \
+ $(all_includes) \
+ $(NULL)
+
+AM_CFLAGS = \
+ -Wall -O3 \
+ -Wno-missing-braces \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOCODING_CFLAGS) \
+ $(NULL)
+
+bin_PROGRAMS = gprsdecode
+
+gprsdecode_SOURCES = \
+ gsmtap.c \
+ rlcmac.c \
+ gprs.c \
+ main.c \
+ $(NULL)
+
+noinst_HEADERS = \
+ l1ctl_proto.h \
+ rlcmac.h \
+ gsmtap.h \
+ gprs.h \
+ $(NULL)
+
+gprsdecode_LDADD = \
+ $(LIBOSMOCODING_LIBS) \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(NULL)