aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Transceiver52M/Makefile.am')
-rw-r--r--tests/Transceiver52M/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/Transceiver52M/Makefile.am b/tests/Transceiver52M/Makefile.am
index 06db5b0..ebd84f6 100644
--- a/tests/Transceiver52M/Makefile.am
+++ b/tests/Transceiver52M/Makefile.am
@@ -16,3 +16,12 @@ endif
if HAVE_SSE4_1
convolve_test_CFLAGS += $(SIMD_FLAGS)
endif
+
+if DEVICE_LMS
+noinst_PROGRAMS += LMSDeviceTest
+LMSDeviceTest_SOURCES = LMSDeviceTest.cpp
+LMSDeviceTest_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LMS_LIBS)
+LMSDeviceTest_LDADD = \
+ $(top_builddir)/Transceiver52M/device/lms/.libs/LMSDevice.o \
+ $(COMMON_LA)
+endif