aboutsummaryrefslogtreecommitdiffstats
path: root/doc/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/examples/Makefile.am')
-rw-r--r--doc/examples/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/doc/examples/Makefile.am b/doc/examples/Makefile.am
index 530c3fa..88d9142 100644
--- a/doc/examples/Makefile.am
+++ b/doc/examples/Makefile.am
@@ -1,4 +1,23 @@
-CFG_FILES = find $(srcdir) -name '*.cfg*' | sed -e 's,^$(srcdir),,'
+OSMOCONF_FILES =
+osmoconfdir = $(sysconfdir)/osmocom
+
+if DEVICE_UHD
+OSMOCONF_FILES += osmo-trx-uhd/osmo-trx-uhd.cfg
+endif
+
+# if DEVICE_USRP1
+# TODO: no usrp1 sample file yet
+# OSMOCONF_FILES += osmo-trx-usrp1/osmo-trx-usrp1.cfg
+# endif
+
+if DEVICE_LMS
+OSMOCONF_FILES += osmo-trx-lms/osmo-trx-lms.cfg
+endif
+
+osmoconf_DATA = $(OSMOCONF_FILES)
+EXTRA_DIST = $(OSMOCONF_FILES)
+
+CFG_FILES = find $(srcdir) -type f -name '*.cfg*' | sed -e 's,^$(srcdir),,'
dist-hook:
for f in $$($(CFG_FILES)); do \