aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/systemd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/systemd/Makefile.am')
-rw-r--r--contrib/systemd/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/contrib/systemd/Makefile.am b/contrib/systemd/Makefile.am
new file mode 100644
index 0000000..21fbb53
--- /dev/null
+++ b/contrib/systemd/Makefile.am
@@ -0,0 +1,18 @@
+if HAVE_SYSTEMD
+SYSTEMD_SERVICES =
+
+if DEVICE_UHD
+SYSTEMD_SERVICES += osmo-trx-uhd.service
+endif
+
+if DEVICE_USRP1
+SYSTEMD_SERVICES += osmo-trx-usrp1.service
+endif
+
+if DEVICE_LMS
+SYSTEMD_SERVICES += osmo-trx-lms.service
+endif
+
+EXTRA_DIST = $(SYSTEMD_SERVICES)
+systemdsystemunit_DATA = $(SYSTEMD_SERVICES)
+endif # HAVE_SYSTEMD