aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f66225..aae151b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,6 +100,11 @@ AC_ARG_WITH(usrp1, [
[enable USRP1 gnuradio based transceiver])
])
+AC_ARG_WITH(lms, [
+ AS_HELP_STRING([--with-lms],
+ [enable LimeSuite gnuradio based transceiver])
+])
+
AC_ARG_WITH(singledb, [
AS_HELP_STRING([--with-singledb],
[enable single daughterboard use on USRP1])
@@ -133,6 +138,10 @@ AS_IF([test "x$with_usrp1" = "xyes"], [
PKG_CHECK_MODULES(USRP, usrp >= 3.3)
])
+AS_IF([test "x$with_lms" = "xyes"], [
+ PKG_CHECK_MODULES(LMS, LimeSuite)
+])
+
AS_IF([test "x$with_uhd" != "xno"],[
PKG_CHECK_MODULES(UHD, uhd >= 003.011,
[AC_DEFINE(USE_UHD_3_11, 1, UHD version 3.11.0 or higher)],
@@ -184,6 +193,7 @@ CHECK_BUILTIN_SUPPORT([__builtin_cpu_supports],
AM_CONDITIONAL(DEVICE_UHD, [test "x$with_uhd" != "xno"])
AM_CONDITIONAL(DEVICE_USRP1, [test "x$with_usrp1" = "xyes"])
+AM_CONDITIONAL(DEVICE_LMS, [test "x$with_lms" = "xyes"])
AM_CONDITIONAL(ARCH_ARM, [test "x$with_neon" = "xyes" || test "x$with_neon_vfpv4" = "xyes"])
AM_CONDITIONAL(ARCH_ARM_A15, [test "x$with_neon_vfpv4" = "xyes"])
@@ -211,6 +221,7 @@ AC_CONFIG_FILES([\
Transceiver52M/device/Makefile \
Transceiver52M/device/uhd/Makefile \
Transceiver52M/device/usrp1/Makefile \
+ Transceiver52M/device/lms/Makefile \
tests/Makefile \
tests/CommonLibs/Makefile \
tests/Transceiver52M/Makefile \