aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/xtrx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Transceiver52M/device/xtrx/Makefile.am')
-rw-r--r--Transceiver52M/device/xtrx/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Transceiver52M/device/xtrx/Makefile.am b/Transceiver52M/device/xtrx/Makefile.am
new file mode 100644
index 0000000..2b99b39
--- /dev/null
+++ b/Transceiver52M/device/xtrx/Makefile.am
@@ -0,0 +1,10 @@
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES) -I${srcdir}/../common
+AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS)
+
+noinst_HEADERS = XTRXDevice.h
+
+noinst_LTLIBRARIES = libdevice.la
+
+libdevice_la_SOURCES = XTRXDevice.cpp