aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/uhd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Transceiver52M/device/uhd/Makefile.am')
-rw-r--r--Transceiver52M/device/uhd/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Transceiver52M/device/uhd/Makefile.am b/Transceiver52M/device/uhd/Makefile.am
index 11b380e..ab63a4a 100644
--- a/Transceiver52M/device/uhd/Makefile.am
+++ b/Transceiver52M/device/uhd/Makefile.am
@@ -1,10 +1,11 @@
include $(top_srcdir)/Makefile.common
-AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES) -I${srcdir}/..
+AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES) -I${srcdir}/../common
AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(UHD_CFLAGS)
noinst_HEADERS = UHDDevice.h
noinst_LTLIBRARIES = libdevice.la
-libdevice_la_SOURCES = UHDDevice.cpp ../smpl_buf.cpp
+libdevice_la_SOURCES = UHDDevice.cpp
+libdevice_la_LIBADD = $(top_builddir)/Transceiver52M/device/common/libdevice_common.la