aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Transceiver52M/device/common/Makefile.am')
-rw-r--r--Transceiver52M/device/common/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Transceiver52M/device/common/Makefile.am b/Transceiver52M/device/common/Makefile.am
new file mode 100644
index 0000000..e14cc38
--- /dev/null
+++ b/Transceiver52M/device/common/Makefile.am
@@ -0,0 +1,12 @@
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES)
+AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LMS_CFLAGS)
+
+
+noinst_HEADERS = radioDevice.h smpl_buf.h
+
+noinst_LTLIBRARIES = libdevice_common.la
+
+libdevice_common_la_SOURCES = \
+ smpl_buf.cpp