aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/arm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Transceiver52M/arm/Makefile.am')
-rw-r--r--Transceiver52M/arm/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Transceiver52M/arm/Makefile.am b/Transceiver52M/arm/Makefile.am
new file mode 100644
index 0000000..6d34daa
--- /dev/null
+++ b/Transceiver52M/arm/Makefile.am
@@ -0,0 +1,21 @@
+if ARCH_ARM
+if ARCH_ARM_A15
+ARCH_FLAGS = -mfpu=neon-vfpv4
+else
+ARCH_FLAGS = -mfpu=neon
+endif
+
+AM_CFLAGS = -Wall $(ARCH_FLAGS) -std=gnu99 -I../common
+AM_CCASFLAGS = $(ARCH_FLAGS)
+
+noinst_LTLIBRARIES = libarch.la
+
+libarch_la_SOURCES = \
+ ../common/convolve_base.c \
+ convert.c \
+ convert_neon.S \
+ convolve.c \
+ convolve_neon.S \
+ scale.c \
+ scale_neon.S
+endif