aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index ec72f8c..52ec995 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -57,7 +57,11 @@ COMMON_SOURCES = \
radioBuffer.cpp \
sigProcLib.cpp \
signalVector.cpp \
- Transceiver.cpp
+ Transceiver.cpp \
+ ChannelizerBase.cpp \
+ Channelizer.cpp \
+ Synthesis.cpp \
+ common/fft.c
libtransceiver_la_SOURCES = \
$(COMMON_SOURCES) \
@@ -79,10 +83,14 @@ noinst_HEADERS = \
Transceiver.h \
USRPDevice.h \
Resampler.h \
+ ChannelizerBase.h \
+ Channelizer.h \
+ Synthesis.h \
common/convolve.h \
common/convert.h \
common/scale.h \
- common/mult.h
+ common/mult.h \
+ common/fft.h
osmo_trx_SOURCES = osmo-trx.cpp
osmo_trx_LDADD = \
@@ -96,5 +104,5 @@ libtransceiver_la_SOURCES += USRPDevice.cpp
osmo_trx_LDADD += $(USRP_LIBS)
else
libtransceiver_la_SOURCES += UHDDevice.cpp
-osmo_trx_LDADD += $(UHD_LIBS)
+osmo_trx_LDADD += $(UHD_LIBS) $(FFTWF_LIBS)
endif