aboutsummaryrefslogtreecommitdiffstats
path: root/CommonLibs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'CommonLibs/Makefile.am')
-rw-r--r--CommonLibs/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/CommonLibs/Makefile.am b/CommonLibs/Makefile.am
index 271a8ef..b338385 100644
--- a/CommonLibs/Makefile.am
+++ b/CommonLibs/Makefile.am
@@ -44,6 +44,7 @@ libcommon_la_SOURCES = \
Utils.cpp
noinst_PROGRAMS = \
+ ThreadsTest \
BitVectorTest \
InterthreadTest \
SocketsTest \
@@ -80,6 +81,10 @@ URLEncodeTest_LDADD = libcommon.la
BitVectorTest_SOURCES = BitVectorTest.cpp
BitVectorTest_LDADD = libcommon.la $(SQLITE_LA)
+ThreadsTest_SOURCES = ThreadsTest.cpp
+ThreadsTest_LDADD = libcommon.la $(SQLITE_LA)
+ThreadsTest_LDFLAGS = -lpthread
+
InterthreadTest_SOURCES = InterthreadTest.cpp
InterthreadTest_LDADD = libcommon.la $(SQLITE_LA)
InterthreadTest_LDFLAGS = -lpthread