aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-05-22 14:10:01 +0200
committerOliver Smith <osmith@sysmocom.de>2019-05-29 12:14:24 +0200
commit76a5013c914a152cd3f7a80488953946ad353441 (patch)
treec197214fcf2cedb5253cdc0621d90b7d22f69990 /debian
parent928177125654c1e596ec3450a68882c031ebb929 (diff)
debian: create -doc subpackage with pdf manuals
I have verified, that the resulting debian packages build in my own OBS namespace (see the -doc packages): https://download.opensuse.org/repositories/home:/osmith42/Debian_9.0/all/ https://build.opensuse.org/project/show/home:osmith42 Depends: Ib7251cca9116151e473798879375cd5eb48ff3ad (osmo-ci) Related: OS#3899 Change-Id: I34858a18a34fc467f274ac164697a242f4cf0df8
Diffstat (limited to 'debian')
-rw-r--r--debian/control12
-rw-r--r--debian/osmo-trx-doc.install1
-rw-r--r--debian/patches/build-for-debian8.patch35
-rwxr-xr-xdebian/rules6
4 files changed, 36 insertions, 18 deletions
diff --git a/debian/control b/debian/control
index ffb9ac1..8ff59f0 100644
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,8 @@ Build-Depends: debhelper (>= 9),
libtalloc-dev,
libusrp-dev,
liblimesuite-dev,
- libosmocore-dev (>= 0.10.0)
+ libosmocore-dev (>= 0.10.0),
+ osmo-gsm-manuals-dev
Standards-Version: 3.9.6
Vcs-Browser: http://cgit.osmocom.org/osmo-trx
Vcs-Git: git://git.osmocom.org/osmo-trx
@@ -89,3 +90,12 @@ Description: SDR transceiver that implements Layer 1 of a GSM BTS (LimeSuite)
3GPP is the "3rd Generation Partnership Project" which is the collaboration
between different telecommunication associations for developing new
generations of mobile phone networks. (post-2G/GSM)
+
+Package: osmo-trx-doc
+Architecture: all
+Section: doc
+Priority: optional
+Depends: ${misc:Depends}
+Description: ${misc:Package} PDF documentation
+ Various manuals: user manual, VTY reference manual and/or
+ protocol/interface manuals.
diff --git a/debian/osmo-trx-doc.install b/debian/osmo-trx-doc.install
new file mode 100644
index 0000000..aa207b5
--- /dev/null
+++ b/debian/osmo-trx-doc.install
@@ -0,0 +1 @@
+usr/share/doc/osmo-trx-doc/*.pdf
diff --git a/debian/patches/build-for-debian8.patch b/debian/patches/build-for-debian8.patch
index cd1f356..6b917c4 100644
--- a/debian/patches/build-for-debian8.patch
+++ b/debian/patches/build-for-debian8.patch
@@ -1,16 +1,16 @@
-Index: osmo-trx/debian/control
-===================================================================
---- osmo-trx.orig/debian/control
-+++ osmo-trx/debian/control
+diff --git a/debian/control b/debian/control
+index 8ff59f0..126c16a 100644
+--- a/debian/control
++++ b/debian/control
@@ -13,7 +13,6 @@ Build-Depends: debhelper (>= 9),
libfftw3-dev,
libtalloc-dev,
libusrp-dev,
- liblimesuite-dev,
- libosmocore-dev (>= 0.10.0)
+ libosmocore-dev (>= 0.10.0),
+ osmo-gsm-manuals-dev
Standards-Version: 3.9.6
- Vcs-Browser: http://cgit.osmocom.org/osmo-trx
-@@ -29,7 +28,7 @@ Package: osmo-trx-dbg
+@@ -30,7 +29,7 @@ Package: osmo-trx-dbg
Architecture: any
Section: debug
Priority: extra
@@ -19,11 +19,10 @@ Index: osmo-trx/debian/control
Description: Debug symbols for the osmo-trx-*
Make debugging possible
-@@ -70,22 +70,3 @@ Description: SDR transceiver that implem
- 3GPP is the "3rd Generation Partnership Project" which is the collaboration
+@@ -72,25 +71,6 @@ Description: SDR transceiver that implements Layer 1 of a GSM BTS (USRP1)
between different telecommunication associations for developing new
generations of mobile phone networks. (post-2G/GSM)
--
+
-Package: osmo-trx-lms
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
@@ -42,16 +41,20 @@ Index: osmo-trx/debian/control
- 3GPP is the "3rd Generation Partnership Project" which is the collaboration
- between different telecommunication associations for developing new
- generations of mobile phone networks. (post-2G/GSM)
-Index: osmo-trx/debian/rules
-===================================================================
---- osmo-trx.orig/debian/rules
-+++ osmo-trx/debian/rules
+-
+ Package: osmo-trx-doc
+ Architecture: all
+ Section: doc
+diff --git a/debian/rules b/debian/rules
+index 627c0c8..d9285e2 100755
+--- a/debian/rules
++++ b/debian/rules
@@ -9,7 +9,7 @@ override_dh_shlibdeps:
dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
override_dh_auto_configure:
-- dh_auto_configure -- --with-uhd --with-usrp1 --with-lms --with-systemdsystemunitdir=/lib/systemd/system
-+ dh_auto_configure -- --with-uhd --with-usrp1 --with-systemdsystemunitdir=/lib/systemd/system
+- dh_auto_configure -- --with-uhd --with-usrp1 --with-lms --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
++ dh_auto_configure -- --with-uhd --with-usrp1 --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_strip:
dh_strip --dbg-package=osmo-trx-dbg
diff --git a/debian/rules b/debian/rules
index 68de706..627c0c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,11 @@ override_dh_shlibdeps:
dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
override_dh_auto_configure:
- dh_auto_configure -- --with-uhd --with-usrp1 --with-lms --with-systemdsystemunitdir=/lib/systemd/system
+ dh_auto_configure -- --with-uhd --with-usrp1 --with-lms --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_strip:
dh_strip --dbg-package=osmo-trx-dbg
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf