aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-12-03 19:15:01 +0100
committerHarald Welte <laforge@gnumonks.org>2018-12-14 20:05:36 +0000
commitaffd3517878327e6177fbdbcf977a55be150898d (patch)
treeb7dc055dbe4087f3799e6b9b18fac38e5d4bba57 /configure.ac
parent03b11620d9314465f8482ff234b78441496111a0 (diff)
configure.ac: check boost only if USRP1 support is enabled
boost is only used in USRPDevice class. It looks like it can be removed entirely quite easily, since only boost::shared_ptr is used for 2 variables. That's left for somebody with the device and willingness to test the changes. Change-Id: I4c3fa3ff58fd552d0cb4c4cf2033615d84c07c96
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 37b70fa..2ce4462 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,8 @@ AS_IF([test "x$with_neon_vfpv4" = "xyes"], [
])
AS_IF([test "x$with_usrp1" = "xyes"], [
+ AC_CHECK_HEADER([boost/config.hpp],[],
+ [AC_MSG_ERROR([boost/config.hpp not found, install e.g. libboost-dev])])
PKG_CHECK_MODULES(USRP, usrp >= 3.3)
])
@@ -234,9 +236,6 @@ AM_CONDITIONAL(ARCH_ARM_A15, [test "x$with_neon_vfpv4" = "xyes"])
PKG_CHECK_MODULES(LIBUSB, libusb-1.0)
PKG_CHECK_MODULES(FFTWF, fftw3f)
-AC_CHECK_HEADER([boost/config.hpp],[],
- [AC_MSG_ERROR([boost/config.hpp not found, install e.g. libboost-dev])])
-
# Generate manuals
AC_ARG_ENABLE(manuals,
[AS_HELP_STRING(