aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Tsou <tom.tsou@ettus.com>2016-10-19 14:29:45 -0700
committerTom Tsou <tom@tsou.cc>2016-10-25 18:48:52 +0000
commit93ca09ea61d044e5f8662b28bf084c808cac4f2c (patch)
tree0f43607be7d6151ab25aa386be9b31cd4015e162 /configure.ac
parent365bc38beec7970d38b2c8644a1998103671684a (diff)
uhd: Set minimum supported version to 3.9.0
Versions of UHD prior to 3.9.0 are no longer supported. Rather then backport and ifdef UHD version specific API and behavioral changes, set minimum support to the current LTS release, which is 3.9.0. Change-Id: Id7d15b52cd4e45f1d856a6ef3a84832a28f2dd04 Signed-off-by: Tom Tsou <tom.tsou@ettus.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7e394c2..b41382f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,12 +97,9 @@ AS_IF([test "x$with_usrp1" = "xyes"], [
])
AS_IF([test "x$with_usrp1" != "xyes"],[
- PKG_CHECK_MODULES(UHD, uhd >= 003.009,
- [AC_DEFINE(USE_UHD_3_9, 1, UHD version 3.9.0 or higher)],
- [PKG_CHECK_MODULES(UHD, uhd >= 003.005.004)]
- )
- AC_DEFINE(USE_UHD, 1, All UHD versions)
+ PKG_CHECK_MODULES(UHD, uhd >= 003.009)
PKG_CHECK_MODULES(FFTWF, fftw3f)
+ AC_DEFINE(USE_UHD, 1, Using UHD driver)
])
AS_IF([test "x$with_singledb" = "xyes"], [