aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric <ewild@sysmocom.de>2022-05-29 02:09:14 +0200
committerEric <ewild@sysmocom.de>2022-07-11 20:33:37 +0200
commit4444e842060685a6abb77154b52b6f93bcf1fef4 (patch)
treecfb11d236cac348a1ec898478dfd3e47a1154fb1 /configure.ac
parentcb3a37a060ee187d5ec9c5ffb5aab90553384b85 (diff)
bladerf support
This currently only supports the bladerf 2.0 with 4sps. Change-Id: I5af0a241c8a174c18faf4952761df58140b29957
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 30a52f9..0d95a42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,6 +138,11 @@ AC_ARG_WITH(ipc, [
[enable IPC])
])
+AC_ARG_WITH(bladerf, [
+ AS_HELP_STRING([--with-bladerf],
+ [enable bladeRF])
+])
+
AC_ARG_WITH(singledb, [
AS_HELP_STRING([--with-singledb],
[enable single daughterboard use on USRP1])
@@ -187,6 +192,10 @@ AS_IF([test "x$with_uhd" = "xyes"],[
)
])
+AS_IF([test "x$with_bladerf" = "xyes"], [
+ PKG_CHECK_MODULES(BLADE, libbladeRF >= 2.0)
+])
+
AS_IF([test "x$with_singledb" = "xyes"], [
AC_DEFINE(SINGLEDB, 1, Define to 1 for single daughterboard)
])
@@ -240,6 +249,7 @@ AM_CONDITIONAL(DEVICE_UHD, [test "x$with_uhd" = "xyes"])
AM_CONDITIONAL(DEVICE_USRP1, [test "x$with_usrp1" = "xyes"])
AM_CONDITIONAL(DEVICE_LMS, [test "x$with_lms" = "xyes"])
AM_CONDITIONAL(DEVICE_IPC, [test "x$with_ipc" = "xyes"])
+AM_CONDITIONAL(DEVICE_BLADE, [test "x$with_bladerf" = "xyes"])
AM_CONDITIONAL(ARCH_ARM, [test "x$with_neon" = "xyes" || test "x$with_neon_vfpv4" = "xyes"])
AM_CONDITIONAL(ARCH_ARM_A15, [test "x$with_neon_vfpv4" = "xyes"])
@@ -326,6 +336,7 @@ AC_CONFIG_FILES([\
Transceiver52M/device/usrp1/Makefile \
Transceiver52M/device/lms/Makefile \
Transceiver52M/device/ipc/Makefile \
+ Transceiver52M/device/bladerf/Makefile \
tests/Makefile \
tests/CommonLibs/Makefile \
tests/Transceiver52M/Makefile \