aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoachim Steiger <jsteiger@sysmocom.de>2019-04-16 17:10:13 +0200
committerHarald Welte <laforge@gnumonks.org>2019-04-17 18:24:11 +0000
commit2875290d9556291182fb33d248ce1324057adf81 (patch)
treeaab3b0140a131f1cc6ebbe17529b1f95427c40ce /configure.ac
parent4ce4555d0e28d461bc5b1f21b62e78d07ab9a2ac (diff)
lms: add device type detection and device specific gains
add device dependant max gain setup - limesdr mini and limenet micro need slightly reduced maximum gains to get a PASS on phase error measurements rework clock reference setup - external clock needs to be selected before calling LMS_Init(), internal can only be set after. remove now unused compat_LMS_VCTCXO* functions - we do not set the VCTXCO directly anymore Change-Id: I3cf905b0a84bc1ec200891762a6646141ee37181
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 2ce4462..bd421aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,20 +162,6 @@ AS_IF([test "x$with_usrp1" = "xyes"], [
AS_IF([test "x$with_lms" = "xyes"], [
PKG_CHECK_MODULES(LMS, LimeSuite)
-
- # LimeSuite dc124e4e2ed9b549b142410af172f0592f9f0c23 > 18.10 broke API compatibility:
- _cflags_save=$CFLAGS
- CFLAGS="$CFLAGS $LMS_CFLAGS"
- AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [[#include <lime/LimeSuite.h>]],
- [[LMS_VCTCXOWrite(NULL, 0, false); LMS_VCTCXORead(NULL, 0, false);]]
- )],
- [AC_DEFINE([HAVE_LMS_VCTCXO_EEPROM_SAVING], [1],
- [LMS_VCTCXO* requires memory parameter])],
- [AC_DEFINE([HAVE_LMS_VCTCXO_EEPROM_SAVING], [0],
- [LMS_VCTCXO* has no memory parameter])])
- CFLAGS=$_cflags_save
])
AS_IF([test "x$with_uhd" != "xno"],[