aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2017-03-20 12:08:42 +0100
committerTom Tsou <tom@tsou.cc>2017-05-19 17:21:45 +0000
commite8ae9fcf387540f1b210f5ece372d0fd070b6249 (patch)
treea2cea15903fda9795776f35d1cee575b558d0ebc /configure.ac
parentf5bf33b287d5c4ce13c0ecac91c8d7f128a24eb5 (diff)
buildenv: Split up SSE3 and SSE4.1 code
Currently we find SSE3 and SSE4.1 code mixed togehter along with generic code in one file. This introduces the risk that the compiler exidantly mixes SSE4.1 instructions into an SSE3, or even worse into a generic code path. This commit splits the SSE3 and SSE4.1 code into separate files and compiles them with the matching target options. Change-Id: I846e190e92f1258cd412d1b2d79b539e204e04b3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f1159c6..7c3c76f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,7 +114,10 @@ AS_IF([test "x$with_singledb" = "xyes"], [
# Find and define supported SIMD extensions
AS_IF([test "x$with_sse" != "xno"], [
- AX_EXT
+ AX_SSE
+], [
+ AM_CONDITIONAL(HAVE_SSE3, false)
+ AM_CONDITIONAL(HAVE_SSE4_1, false)
])
AM_CONDITIONAL(USRP1, [test "x$with_usrp1" = "xyes"])