aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Tsou <tom.tsou@ettus.com>2017-01-19 13:44:02 -0800
committerTom Tsou <tom.tsou@ettus.com>2017-01-19 13:48:15 -0800
commit80cb08071b2ef60b65db24017a1f35583bc09b5c (patch)
tree0670045ce01bd8d9bb9812dbe870bb0df7bcfe2b /configure.ac
parent44c7f41d7531d22d31edf345cedf305ab9083b20 (diff)
Revert "uhd: Set minimum supported version to 3.9.0"
This reverts commit 93ca09ea61d044e5f8662b28bf084c808cac4f2c. Ettus Research recommends the use of 3.9 series of UHD releases, but requiring this version has lead to issues with broken OBS and packaged binaries by Debian, Ubuntu, and other distributions. Change-Id: Ie6b175ac6d46d091937380c79fdd0125b16ec75f Signed-off-by: Tom Tsou <tom.tsou@ettus.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b41382f..7e394c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,9 +97,12 @@ AS_IF([test "x$with_usrp1" = "xyes"], [
])
AS_IF([test "x$with_usrp1" != "xyes"],[
- PKG_CHECK_MODULES(UHD, uhd >= 003.009)
+ PKG_CHECK_MODULES(UHD, uhd >= 003.009,
+ [AC_DEFINE(USE_UHD_3_9, 1, UHD version 3.9.0 or higher)],
+ [PKG_CHECK_MODULES(UHD, uhd >= 003.005.004)]
+ )
+ AC_DEFINE(USE_UHD, 1, All UHD versions)
PKG_CHECK_MODULES(FFTWF, fftw3f)
- AC_DEFINE(USE_UHD, 1, Using UHD driver)
])
AS_IF([test "x$with_singledb" = "xyes"], [