aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Tsou <tom@tsou.cc>2013-04-08 14:41:11 -0400
committerAlexander Chemeris <Alexander.Chemeris@gmail.com>2013-06-24 01:46:34 +0400
commit03669856b74bd1e82a3986a5e05154fec88942ac (patch)
tree9b551232c252925a767c684a0e2eef2cac1ffe7c /configure.ac
parent5d0e392b216c3c4e3d6d701650cb13e50e19c35a (diff)
Transceiver52M: Set resampling option automatically based on device
Remove the built time resampling selection and link both options. Move the normal push/pullBuffer() calls back to the base class and overload them in the inherited resampling class. USRP2/N2xx devices are the only devices that require resampling so return that resampling is necessary on the device open(), which is the point at which the device type will be known. Signed-off-by: Thomas Tsou <tom@tsou.cc>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 1c96f51..3cf2783 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,11 +72,6 @@ AC_ARG_WITH(singledb, [
[enable single daughterboard use on USRP1])
])
-AC_ARG_WITH(resamp, [
- AS_HELP_STRING([--with-resamp],
- [enable resampling for non-52MHz devices])
-])
-
AC_ARG_WITH(extref, [
AS_HELP_STRING([--with-extref],
[enable external reference on UHD devices])
@@ -102,10 +97,6 @@ AS_IF([test "x$with_uhd" = "xyes"],[
AC_DEFINE(USE_UHD, 1, Define to 1 if using UHD)
])
-AS_IF([test "x$with_resamp" = "xyes"], [
- AC_DEFINE(RESAMPLE, 1, Define to 1 for resampling)
-])
-
AS_IF([test "x$with_extref" = "xyes"], [
AC_DEFINE(EXTREF, 1, Define to 1 for external reference)
])
@@ -114,7 +105,6 @@ AS_IF([test "x$with_singledb" = "xyes"], [
AC_DEFINE(SINGLEDB, 1, Define to 1 for single daughterboard)
])
-AM_CONDITIONAL(RESAMPLE, [test "x$with_resamp" = "xyes"])
AM_CONDITIONAL(UHD, [test "x$with_uhd" = "xyes"])
AM_CONDITIONAL(USRP1, [test "x$with_usrp1" = "xyes"])