aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/uhd/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-04-24 16:16:06 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-04-24 18:46:48 +0200
commit2128a308eb06aab9a94f479794d334705ae0505e (patch)
tree1e35153a2d50b8ab31cf501fa2bff3353ff7bd47 /Transceiver52M/device/uhd/Makefile.am
parent43fedb656b9e99e1a3445998834918df98c9679a (diff)
Move device specific files to device subdir
Diffstat (limited to 'Transceiver52M/device/uhd/Makefile.am')
-rw-r--r--Transceiver52M/device/uhd/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Transceiver52M/device/uhd/Makefile.am b/Transceiver52M/device/uhd/Makefile.am
new file mode 100644
index 0000000..bb34d2f
--- /dev/null
+++ b/Transceiver52M/device/uhd/Makefile.am
@@ -0,0 +1,8 @@
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES) -I${srcdir}/..
+AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(UHD_CFLAGS)
+
+noinst_LTLIBRARIES = libdevice.la
+
+libdevice_la_SOURCES = UHDDevice.cpp