aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/lms/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2019-05-03 16:15:06 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2019-05-06 11:23:36 +0200
commitdcbcfa58e4132ba526cfd845cfeec7b38c8ff5d5 (patch)
tree83718aef9f376bc9bf0bd02fb36df066124445da /Transceiver52M/device/lms/Makefile.am
parentb5def414b8c485c8fb434a427ed8f4df427ae224 (diff)
lms: Use smpl_buf to recover from timestamp jumps
Also take the chance to make sure we handle properly short reads (keep reading again). Both scenarios can be tested by running osmo-trx-lms and then using on a terminal: sudo kill -STOP `pidof osmo-trx-lms`; sleep 0.5; sudo kill -CONT `pidof osmo-trx-lms` Fixes: OS#3339 Change-Id: Idfc4e69acc30afb11440b6b9cbdcfa09ff920265
Diffstat (limited to 'Transceiver52M/device/lms/Makefile.am')
-rw-r--r--Transceiver52M/device/lms/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Transceiver52M/device/lms/Makefile.am b/Transceiver52M/device/lms/Makefile.am
index 682cf26..77fd0e9 100644
--- a/Transceiver52M/device/lms/Makefile.am
+++ b/Transceiver52M/device/lms/Makefile.am
@@ -8,3 +8,4 @@ noinst_HEADERS = LMSDevice.h
noinst_LTLIBRARIES = libdevice.la
libdevice_la_SOURCES = LMSDevice.cpp
+libdevice_la_LIBADD = $(top_builddir)/Transceiver52M/device/common/libdevice_common.la