aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/ipc/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <vyanitskiy@sysmocom.de>2020-10-24 06:43:27 +0700
committerfixeria <vyanitskiy@sysmocom.de>2020-10-24 23:41:57 +0000
commit24cb0c9948403427944bac234786eaa985ab6845 (patch)
tree435e965b0633bc74e0b6fa698f0070e356474852 /Transceiver52M/device/ipc/Makefile.am
parent6be2d155414daff3cee3d48637f046ac4c4f1d99 (diff)
device: drop unreasonable LIBOSMO{CTRL,VTY}_{CFLAGS,LIBS}
Neither VTY nor CTRL API is used in device specific code, excluding the 'uhd' where osmo_cpu_sched_vty_apply_localthread() is called. Change-Id: I568b443da4b96c005734d749faa22b9c7440f951
Diffstat (limited to 'Transceiver52M/device/ipc/Makefile.am')
-rw-r--r--Transceiver52M/device/ipc/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Transceiver52M/device/ipc/Makefile.am b/Transceiver52M/device/ipc/Makefile.am
index e4dc51a..4fe0090 100644
--- a/Transceiver52M/device/ipc/Makefile.am
+++ b/Transceiver52M/device/ipc/Makefile.am
@@ -1,8 +1,8 @@
include $(top_srcdir)/Makefile.common
AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES) -I${srcdir}/../common
-AM_CFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS)
-AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS)
+AM_CFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS)
+AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS)
AM_LDFLAGS = -lpthread -lrt
noinst_HEADERS = IPCDevice.h shm.h ipc_shm.h ipc_chan.h ipc_sock.h
@@ -32,8 +32,7 @@ ipc_driver_test_SOURCES = ipc-driver-test.c uhdwrap.cpp ipc_shm.c ipc_chan.c ipc
ipc_driver_test_LDADD = \
shm.lo \
$(LIBOSMOCORE_LIBS) \
- $(LIBOSMOCTRL_LIBS) \
- $(LIBOSMOVTY_LIBS)
+ $(NULL)
ipc_driver_test_CXXFLAGS = $(AM_CXXFLAGS) $(UHD_CFLAGS)
ipc_driver_test_CPPFLAGS = $(AM_CPPFLAGS) $(UHD_CFLAGS)
ipc_driver_test_CFLAGS = $(AM_CFLAGS) $(UHD_CFLAGS)