aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/arch/x86/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-04-24 15:22:57 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-04-24 15:22:59 +0200
commit43fedb656b9e99e1a3445998834918df98c9679a (patch)
treef41f62fccbbc59c88de4c84bd751b10cb1117a8a /Transceiver52M/arch/x86/Makefile.am
parent53bdb7f82abbbcd7ecbb31c12ba877661bc6852f (diff)
Move arch specific fiels to arch subdir
Take the chance to update some includes using files available in that subdir to have them ina more uniform way. Change-Id: Ibda3c54fd4dc3f6b845cc373f1a1e6b758c1ea82
Diffstat (limited to 'Transceiver52M/arch/x86/Makefile.am')
-rw-r--r--Transceiver52M/arch/x86/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/Transceiver52M/arch/x86/Makefile.am b/Transceiver52M/arch/x86/Makefile.am
new file mode 100644
index 0000000..f39dde5
--- /dev/null
+++ b/Transceiver52M/arch/x86/Makefile.am
@@ -0,0 +1,28 @@
+AM_CFLAGS = -Wall -std=gnu99 -I${srcdir}/../common
+
+noinst_LTLIBRARIES = libarch.la
+noinst_LTLIBRARIES += libarch_sse_3.la
+noinst_LTLIBRARIES += libarch_sse_4_1.la
+
+libarch_la_LIBADD = $(top_builddir)/Transceiver52M/arch/common/libarch_common.la
+
+# SSE 3 specific code
+if HAVE_SSE3
+libarch_sse_3_la_SOURCES = \
+ convert_sse_3.c \
+ convolve_sse_3.c
+libarch_sse_3_la_CFLAGS = $(AM_CFLAGS) -msse3
+libarch_la_LIBADD += libarch_sse_3.la
+endif
+
+# SSE 4.1 specific code
+if HAVE_SSE4_1
+libarch_sse_4_1_la_SOURCES = \
+ convert_sse_4_1.c
+libarch_sse_4_1_la_CFLAGS = $(AM_CFLAGS) -msse4.1
+libarch_la_LIBADD += libarch_sse_4_1.la
+endif
+
+libarch_la_SOURCES = \
+ convert.c \
+ convolve.c