aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authordburgess <dburgess@19bc5d8c-e614-43d4-8b26-e1612bc8e597>2011-10-12 07:44:40 +0000
committerdburgess <dburgess@19bc5d8c-e614-43d4-8b26-e1612bc8e597>2011-10-12 07:44:40 +0000
commitb3a0ca42db0bd08c58b9370a1398528016e6953f (patch)
tree1e81558498b765f0faac4c8588c18fbc4bfc8dfb /Transceiver52M/Makefile.am
parentec3d77d0eaa12c102893490766557dd4d4efd029 (diff)
Adding in the missing Transceiver52M directory
git-svn-id: http://wush.net/svn/range/software/public/openbts/trunk@2307 19bc5d8c-e614-43d4-8b26-e1612bc8e597
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am88
1 files changed, 88 insertions, 0 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
new file mode 100644
index 0000000..4669b99
--- /dev/null
+++ b/Transceiver52M/Makefile.am
@@ -0,0 +1,88 @@
+#
+# Copyright 2008 Free Software Foundation, Inc.
+# Copyright 2010 Range Networks, Inc.
+#
+# This software is distributed under the terms of the GNU Public License.
+# See the COPYING file in the main directory for details.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(USRP_CFLAGS)
+AM_CXXFLAGS = -ldl -lpthread
+
+#rev2dir = $(datadir)/usrp/rev2
+#rev4dir = $(datadir)/usrp/rev4
+
+#dist_rev2_DATA = std_inband.rbf
+#dist_rev4_DATA = std_inband.rbf
+
+EXTRA_DIST = \
+ README \
+ README.Talgorithm
+
+noinst_LTLIBRARIES = libtransceiver.la
+
+libtransceiver_la_SOURCES = \
+ radioInterface.cpp \
+ sigProcLib.cpp \
+ Transceiver.cpp \
+ USRPDevice.cpp \
+ DummyLoad.cpp
+
+noinst_PROGRAMS = \
+ USRPping \
+ transceiver \
+ sigProcLibTest
+
+noinst_HEADERS = \
+ Complex.h \
+ radioInterface.h \
+ radioDevice.h \
+ sigProcLib.h \
+ Transceiver.h \
+ USRPDevice.h \
+ DummyLoad.h
+
+USRPping_SOURCES = USRPping.cpp
+USRPping_LDADD = \
+ libtransceiver.la \
+ $(COMMON_LA) $(SQLITE_LA) \
+ $(USRP_LIBS)
+
+transceiver_SOURCES = runTransceiver.cpp
+transceiver_LDADD = \
+ libtransceiver.la \
+ $(GSM_LA) \
+ $(COMMON_LA) $(SQLITE_LA) \
+ $(USRP_LIBS)
+
+sigProcLibTest_SOURCES = sigProcLibTest.cpp
+sigProcLibTest_LDADD = \
+ libtransceiver.la \
+ $(GSM_LA) \
+ $(COMMON_LA) $(SQLITE_LA) \
+ $(USRP_LIBS)
+
+
+MOSTLYCLEANFILES +=
+
+#radioInterface.cpp
+#ComplexTest.cpp
+#sigProcLibTest.cpp
+#sweepGenerator.cpp
+#testRadio.cpp
+