aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-04-24 18:49:03 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-04-24 19:17:22 +0200
commitf3d7f443a01e2a021a32cdbb402a38fdcedd2fee (patch)
tree7a2823c8395e719867e6b5da11c040cbd1bc0d31 /Transceiver52M/Makefile.am
parente564f0fd846a359944e050a92a5b50c4f2bdf3d0 (diff)
Build one osmo-trx binary for each device support enabled
Same way as we do in osmo-bts. After this commit, osmo-trx no longer exists. Instead, osmo-trx-uhd and osmo-trx-usrp1 are generated based on configure flags enabled. A new flag --with(out)-uhd has been added to enable/disable build of osmo-trx with UHD backend. It is left enabled by default to keep compatibility with older build scripts. Binary with USRP1 backend must still be manually enabled with --with-usrp1 flag. Change-Id: Iea8c0d7434762713a53440d29bf3ebd84accb262
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am25
1 files changed, 15 insertions, 10 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index ae4a5bc..3a872ef 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -80,19 +80,24 @@ COMMON_LDADD = \
$(LIBOSMOCTRL_LIBS) \
$(LIBOSMOVTY_LIBS)
-bin_PROGRAMS = osmo-trx
-osmo_trx_SOURCES = osmo-trx.cpp
+bin_PROGRAMS =
+
+if DEVICE_UHD
+bin_PROGRAMS += osmo-trx-uhd
+osmo_trx_uhd_SOURCES = osmo-trx.cpp
+osmo_trx_uhd_LDADD = \
+ $(COMMON_LDADD) \
+ $(UHD_LIBS) \
+ $(builddir)/device/uhd/libdevice.la
+osmo_trx_uhd_CPPFLAGS = $(AM_CPPFLAGS) $(UHD_CFLAGS)
+endif
if DEVICE_USRP1
-osmo_trx_LDADD = \
+bin_PROGRAMS += osmo-trx-usrp1
+osmo_trx_usrp1_SOURCES = osmo-trx.cpp
+osmo_trx_usrp1_LDADD = \
$(COMMON_LDADD) \
$(USRP_LIBS) \
$(builddir)/device/usrp1/libdevice.la
-osmo_trx_CPPFLAGS = $(AM_CPPFLAGS) $(USRP_CFLAGS)
-else
-osmo_trx_LDADD = \
- $(COMMON_LDADD) \
- $(UHD_LIBS) \
- $(builddir)/device/uhd/libdevice.la
-osmo_trx_CPPFLAGS = $(AM_CPPFLAGS) $(UHD_CFLAGS)
+osmo_trx_usrp1_CPPFLAGS = $(AM_CPPFLAGS) $(USRP_CFLAGS)
endif