aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-03-07 14:39:26 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2018-03-07 19:46:42 +0100
commitb35cba613ab2295ec99c897c9a80660ac2738491 (patch)
treeb39e1be6d01a1731b469e3e5c430aa83d1a49244 /Transceiver52M/Makefile.am
parent8dffadb8da92e7b0af97362936a117ebfbd9323d (diff)
Makefile.am: Avoid using subdir if arch is not required
There's no need in going a level deeper if we already know nothing's going to be done. This way we also get cleaner make outputs. Reference: https://www.gnu.org/software/automake/manual/html_node/Conditional-Subdirectories.html#Conditional-Subdirectories Related: OS#3029 Change-Id: I3ff57ab14edc575904e8137929a0ef02c95e03af
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index 3c1b86c..187a335 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -24,7 +24,11 @@ include $(top_srcdir)/Makefile.common
AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES) -I${srcdir}/common
AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS)
-SUBDIRS = arm x86
+if ARCH_ARM
+SUBDIRS = arm
+else
+SUBDIRS = x86
+endif
if USRP1
AM_CPPFLAGS += $(USRP_CFLAGS)