aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authorAlexander Chemeris <Alexander.Chemeris@gmail.com>2013-09-06 00:35:57 +0400
committerAlexander Chemeris <Alexander.Chemeris@gmail.com>2013-09-06 00:35:57 +0400
commit0b8aa00bc7b8233fad019fb92d63066b1be9b8e4 (patch)
treec570da132ac2214f816317424a07904cebe8dd33 /Transceiver52M/Makefile.am
parent1ed2e27d1931ee940ac67d818f40465edfef1c4e (diff)
conditional load testing (selected at compile time), turned on by default.achemeris/load_testing
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index a7da44e..d54356e 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -21,9 +21,10 @@
include $(top_srcdir)/Makefile.common
+LOAD_TEST_FLAGS = -DTRX_LOAD_TESTING
AM_CFLAGS = $(STD_DEFINES_AND_INCLUDES) -std=gnu99 -march=native
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES)
-AM_CXXFLAGS = -ldl -lpthread
+AM_CXXFLAGS = -ldl -lpthread $(LOAD_TEST_FLAGS)
#UHD wins if both are defined
if UHD