aboutsummaryrefslogtreecommitdiffstats
path: root/CommonLibs/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-09-03 16:50:49 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-09-04 16:35:23 +0200
commitdb936b9b55fb825acbe7df4246097fe23d405612 (patch)
treedc9a60041b19dbb741ec281cf2e68fbe02d35735 /CommonLibs/Makefile.am
parent49ad7590728880f967dbc31876679a9dbd10d014 (diff)
osmo-trx: Add osmo_signal to stop whole transceiver chain correctly on error
Transceiver::stop() can only be called from either CTRL iface thread or from main thread (running osmocom loop). That's because stop attempts to cancel and then join all the other threads, which would then lock if attempting to stop from some of them. As a result, the best option is to indicate to the user of the transceiver option (osmo-trx.cpp) to stop it in a correct fashion by destroying the object from the main thread. Change-Id: Iac1d2dbe2328e735db2d4b933cb67b1af1babca1
Diffstat (limited to 'CommonLibs/Makefile.am')
-rw-r--r--CommonLibs/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/CommonLibs/Makefile.am b/CommonLibs/Makefile.am
index 2332acb..3173397 100644
--- a/CommonLibs/Makefile.am
+++ b/CommonLibs/Makefile.am
@@ -49,4 +49,5 @@ noinst_HEADERS = \
Logger.h \
trx_vty.h \
debug.h \
+ osmo_signal.h \
config_defs.h