aboutsummaryrefslogtreecommitdiffstats
path: root/CommonLibs/Makefile.am
diff options
context:
space:
mode:
authorAlexander Chemeris <Alexander.Chemeris@gmail.com>2017-04-02 12:45:36 +0200
committerTom Tsou <tom@tsou.cc>2017-06-08 18:33:47 +0000
commit082bbbf8feec0a9a86d7484476e768971fe3b646 (patch)
tree0cc22d2755a560ce4109a81bcbc6fab412cdbdf8 /CommonLibs/Makefile.am
parent3bd763d2a10e19980505c90242a2eae9e2f6b4cb (diff)
PRBS: a Pseudo-random binary sequence (PRBS) generator class.
Implemeted with a Galois LFSR for speed and flexibility compared to Fibonacci version. Aliases for three popular PRBS' are added for convenience - PRBS9, PRBS15 and PRBS64. Note that we can't test PRBS64 completely, because the sequence is too long to be generated. Change-Id: Ib5331ba5d0b5819929541686fdd87905e2177b74
Diffstat (limited to 'CommonLibs/Makefile.am')
-rw-r--r--CommonLibs/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/CommonLibs/Makefile.am b/CommonLibs/Makefile.am
index f0f1061..18ec2f7 100644
--- a/CommonLibs/Makefile.am
+++ b/CommonLibs/Makefile.am
@@ -42,6 +42,7 @@ libcommon_la_SOURCES = \
noinst_PROGRAMS = \
BitVectorTest \
+ PRBSTest \
InterthreadTest \
SocketsTest \
TimevalTest \
@@ -53,6 +54,7 @@ noinst_PROGRAMS = \
noinst_HEADERS = \
BitVector.h \
+ PRBS.h \
Interthread.h \
LinkedLists.h \
Sockets.h \
@@ -66,6 +68,8 @@ noinst_HEADERS = \
BitVectorTest_SOURCES = BitVectorTest.cpp
BitVectorTest_LDADD = libcommon.la $(SQLITE3_LIBS)
+PRBSTest_SOURCES = PRBSTest.cpp
+
InterthreadTest_SOURCES = InterthreadTest.cpp
InterthreadTest_LDADD = libcommon.la
InterthreadTest_LDFLAGS = -lpthread