aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/vlr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/vlr/Makefile.am')
-rw-r--r--openbsc/tests/vlr/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/openbsc/tests/vlr/Makefile.am b/openbsc/tests/vlr/Makefile.am
new file mode 100644
index 000000000..2208a6f59
--- /dev/null
+++ b/openbsc/tests/vlr/Makefile.am
@@ -0,0 +1,22 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -Wall -ggdb3 \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ $(LIBOSMOABIS_CFLAGS) \
+ $(NULL)
+AM_LDFLAGS = $(COVERAGE_LDFLAGS)
+
+noinst_PROGRAMS = vlr_test
+
+vlr_test_SOURCES = vlr_test.c
+vlr_test_LDADD = \
+ $(top_builddir)/src/libvlr/libvlr.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOVTY_LIBS) \
+ $(LIBOSMOABIS_LIBS) \
+ $(LIBRARY_DL) \
+ $(LIBCRYPTO_LIBS) \
+ $(NULL)