aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/gbproxy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/gbproxy/Makefile.am')
-rw-r--r--openbsc/tests/gbproxy/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/openbsc/tests/gbproxy/Makefile.am b/openbsc/tests/gbproxy/Makefile.am
index 4577e3aa8..18d77a848 100644
--- a/openbsc/tests/gbproxy/Makefile.am
+++ b/openbsc/tests/gbproxy/Makefile.am
@@ -7,6 +7,8 @@ EXTRA_DIST = gbproxy_test.ok
noinst_PROGRAMS = gbproxy_test
gbproxy_test_SOURCES = gbproxy_test.c
+gbproxy_test_LDFLAGS = \
+ -Wl,--wrap=RAND_bytes
gbproxy_test_LDADD = \
$(top_builddir)/src/gprs/gb_proxy.o \
$(top_builddir)/src/gprs/gb_proxy_patch.o \
@@ -22,4 +24,4 @@ gbproxy_test_LDADD = \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGB_LIBS) \
$(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) \
$(LIBOSMOABIS_LIBS) $(LIBRARY_DL) \
- -lrt
+ $(LIBCRYPTO_LIBS) -lrt