aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/channel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsc/tests/channel/Makefile.am')
-rw-r--r--openbsc/tests/channel/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/openbsc/tests/channel/Makefile.am b/openbsc/tests/channel/Makefile.am
new file mode 100644
index 000000000..60defe0a6
--- /dev/null
+++ b/openbsc/tests/channel/Makefile.am
@@ -0,0 +1,14 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall -ggdb3
+
+noinst_PROGRAMS = channel_test
+
+channel_test_SOURCES = channel_test.c \
+ $(top_srcdir)/src/db.c \
+ $(top_srcdir)/src/gsm_subscriber.c \
+ $(top_srcdir)/src/debug.c \
+ $(top_srcdir)/src/timer.c \
+ $(top_srcdir)/src/select.c \
+ $(top_srcdir)/src/gsm_data.c
+channel_test_LDADD = -ldl -ldbi
+