aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 13 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 4fe1f467d..cfd692a48 100755
--- a/debian/rules
+++ b/debian/rules
@@ -46,8 +46,8 @@
# debmake generated override targets
# Set options for ./configure
-CONFIGURE_FLAGS += --enable-iu
-override_dh_configure:
+CONFIGURE_FLAGS += --enable-iu --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
+override_dh_auto_configure:
dh_auto_configure -- $(CONFIGURE_FLAGS)
#
# Do not install libtool archive, python .pyc .pyo
@@ -56,6 +56,14 @@ override_dh_configure:
# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
override_dh_strip:
- dh_strip --dbg-package=osmo-sgsn-dbg
- dh_strip --dbg-package=osmo-gtphub-dbg
- dh_strip --dbg-package=osmo-gbproxy-dbg
+ dh_strip -posmo-sgsn --dbg-package=osmo-sgsn-dbg
+ dh_strip -posmo-gtphub --dbg-package=osmo-gtphub-dbg
+ dh_strip -posmo-gbproxy --dbg-package=osmo-gbproxy-dbg
+
+# Print test results in case of a failure
+override_dh_auto_test:
+ dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf