aboutsummaryrefslogtreecommitdiffstats
path: root/tests/db/Makefile.am
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2009-04-12 05:37:07 +0000
committerHolger Freyther <zecke@selfish.org>2009-04-12 05:37:07 +0000
commitbab9cd9a2715e416664d08a56bdacefd6e921e4f (patch)
tree23e42666413bb7b3068c45f63ca8089a611f1731 /tests/db/Makefile.am
parent3190a89e386183d9e17264c5d30f42bba5d8b03e (diff)
[tests] Change the db_test to link to the libopenbsc.a
This should keep the test compiling in the future. It will link to the libopenbsc.a to get all symbols. We do this in the other tests too.
Diffstat (limited to 'tests/db/Makefile.am')
-rw-r--r--tests/db/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/db/Makefile.am b/tests/db/Makefile.am
index 5c9c784c6..3d9722c50 100644
--- a/tests/db/Makefile.am
+++ b/tests/db/Makefile.am
@@ -3,6 +3,6 @@ AM_CFLAGS=-Wall -ggdb3
noinst_PROGRAMS = db_test
-db_test_SOURCES = db_test.c $(top_srcdir)/src/db.c $(top_srcdir)/src/gsm_subscriber.c
-db_test_LDADD = -ldl -ldbi
+db_test_SOURCES = db_test.c
+db_test_LDADD = $(top_builddir)/src/libbsc.a -ldl -ldbi