aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2019-08-14 20:22:59 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2019-08-20 17:48:47 +0200
commit5ed3f67f96ce29a1afcd9db89b45752c1d69ac8c (patch)
tree4ca7dae3c65e9d1eda8354b11cb5ac2847af937d /tests/Makefile.am
parenta299d6511486dc384af920592f1ff8488e8fcf0c (diff)
tests: Introduce vty-transcript-test tests
Add a few commands to make sure it's working fine, and print all available timers with default values. Change-Id: Ifd092b9561d49be1f62769d95ba49f6e4aeb4066
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am31
1 files changed, 27 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 035cfb010..6c392af9c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -33,6 +33,7 @@ EXTRA_DIST = \
$(TESTSUITE) \
vty_test_runner.py \
ctrl_test_runner.py \
+ test_nodes.vty \
$(NULL)
TESTSUITE = $(srcdir)/testsuite
@@ -43,15 +44,37 @@ DISTCLEANFILES = \
if ENABLE_EXT_TESTS
python-tests: $(BUILT_SOURCES)
+ $(MAKE) vty-test
+ $(MAKE) ctrl-python-test
+else
+python-tests: $(BUILT_SOURCES)
+ echo "Not running python-based tests (determined at configure-time)"
+endif
+
+vty-python-test: $(BUILT_SOURCES)
osmotestvty.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
osmotestconfig.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
$(srcdir)/vty_test_runner.py -w $(abs_top_builddir) -v
+ rm -f $(top_builddir)/sms.db $(top_builddir)/gsn_restart $(top_builddir)/gtphub_restart_count
+
+# To update the VTY script from current application behavior,
+# pass -u to vty_script_runner.py by doing:
+# make vty-transcript-test U=-u
+vty-transcript-test:
+ osmo_verify_transcript_vty.py -v \
+ -n OsmoSGSN -p 4245 \
+ -r "$(top_builddir)/src/gprs/osmo-sgsn -c $(top_srcdir)/doc/examples/osmo-sgsn/osmo-sgsn.cfg" \
+ $(U) $${T:-$(srcdir)/*.vty}
+ rm -f $(builddir)/sms.db $(builddir)/gsn_restart
+
+# don't run multiple tests concurrently so that the ports don't conflict
+vty-test:
+ $(MAKE) vty-python-test
+ $(MAKE) vty-transcript-test
+
+ctrl-python-test: $(BUILT_SOURCES)
$(srcdir)/ctrl_test_runner.py -w $(abs_top_builddir) -v
rm -f $(top_builddir)/sms.db $(top_builddir)/gsn_restart $(top_builddir)/gtphub_restart_count
-else
-python-tests: $(BUILT_SOURCES)
- echo "Not running python-based tests (determined at configure-time)"
-endif
check-local: atconfig $(TESTSUITE)
$(SHELL) '$(TESTSUITE)' $(TESTSUITEFLAGS)