aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-07-20 17:57:37 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2017-08-27 17:40:52 +0200
commita4cd7f88ae6ba6cac4784bea03a7ec47abe8c764 (patch)
tree9457626782a2da8b28b744be66269f3522f82415 /tests/Makefile.am
parentd287114512d44bf1034af97b9eb7b0582031d067 (diff)
fix make distcheck with python tests
- bscs.config needed by the vty tests was not picked up as a dist file, because its suffix is not 'cfg'. Rename to *.cfg. Apply this rename in vty_test_runner.py and osmo-bsc_nat.cfg. - Remove restart counters after external tests, otherwise distcheck complains about uncleaned files. - Add contrib/ipa.py to EXTRA_DIST, hence add a Makefile.am to contrib/. Otherwise the python tests cannot find that dependency. Change-Id: I42b55cb1125099afc3a8e3f87c0e398426b2e2a9
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9cbc1c172..72161eeea 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -87,7 +87,7 @@ python-tests: $(BUILT_SOURCES)
if BUILD_SMPP
$(PYTHON) $(srcdir)/smpp_test_runner.py -w $(abs_top_builddir) -v
endif
- rm -f $(top_builddir)/hlr.sqlite3
+ rm -f $(top_builddir)/hlr.sqlite3 $(top_builddir)/gsn_restart $(top_builddir)/gtphub_restart_count
else
python-tests: $(BUILT_SOURCES)
echo "Not running python-based tests (determined at configure-time)"