aboutsummaryrefslogtreecommitdiffstats
path: root/src/sgsn/Makefile.am
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2019-09-28 21:22:53 +0200
committerlynxis lazus <lynxis@fe80.eu>2019-10-03 19:51:03 +0000
commite30f19542bcfa3493dc428a638580f34c773081b (patch)
tree0b0e8d0e05185d5324b4405a9c0bcdc7ebf9607d /src/sgsn/Makefile.am
parenta8f782502b48f685464a287c01306af225fa7ec5 (diff)
Avoid compiling unneeded files when building without Iu
Remove gprs_ranap.c and gprs_mm_state_iu_fsm.c from the Makefile when building without IU. Change-Id: I2386f8e86bbf0b87eedce9f57eb86b1b64998a69
Diffstat (limited to 'src/sgsn/Makefile.am')
-rw-r--r--src/sgsn/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/sgsn/Makefile.am b/src/sgsn/Makefile.am
index 8bc1abb86..6a7392baf 100644
--- a/src/sgsn/Makefile.am
+++ b/src/sgsn/Makefile.am
@@ -45,8 +45,6 @@ osmo_sgsn_SOURCES = \
gprs_gmm.c \
gprs_gmm_fsm.c \
gprs_mm_state_gb_fsm.c \
- gprs_mm_state_iu_fsm.c \
- gprs_ranap.c \
gprs_sgsn.c \
gprs_sm.c \
gprs_sndcp.c \
@@ -87,4 +85,9 @@ osmo_sgsn_LDADD += \
$(LIBOSMORANAP_LIBS) \
$(LIBASN1C_LIBS) \
$(NULL)
+
+osmo_sgsn_SOURCES += \
+ gprs_mm_state_iu_fsm.c \
+ gprs_ranap.c
+
endif