aboutsummaryrefslogtreecommitdiffstats
path: root/src/libiu/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-07-05 15:19:52 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2017-08-30 14:12:37 +0200
commita7a3947b9bd82e30124baab5c71925f20228ad9a (patch)
tree8ff1590450428ec95acff27a6c615498fcdd719b /src/libiu/Makefile.am
parente0437166ffd44cce0515b0f1ce26d0a979ef48c2 (diff)
move libiu to osmo-iuh/libosmo-ranap
Remove libiu here, use the functions from libosmo-ranap instead, by applying the ranap_ / RANAP_ prefix. Corresponding change-id in osmo-iuh.git is I6a3f7ad15be03fb94689b4af6ccfa828c25f45c0 To be able to run the msc_vlr tests for RAN_UTRAN_IU without Iu client headers available, add iu_dummy.h, containing mere function signatures that match iu_dummy.c and a mostly empty struct ranap_ue_conn_ctx. Make sure we can build with and without --enable-iu: include osmo-iuh headers only with --enable-iu. Change-Id: Ib8c4fcdb4766c5e575618b95ce16dce51063206b
Diffstat (limited to 'src/libiu/Makefile.am')
-rw-r--r--src/libiu/Makefile.am28
1 files changed, 0 insertions, 28 deletions
diff --git a/src/libiu/Makefile.am b/src/libiu/Makefile.am
deleted file mode 100644
index e5f9e2751..000000000
--- a/src/libiu/Makefile.am
+++ /dev/null
@@ -1,28 +0,0 @@
-AM_CPPFLAGS = \
- $(all_includes) \
- -I$(top_srcdir)/include \
- -I$(top_builddir) \
- $(NULL)
-
-AM_CFLAGS = \
- -Wall \
- $(COVERAGE_CFLAGS) \
- $(LIBCRYPTO_CFLAGS) \
- $(LIBASN1C_CFLAGS) \
- $(LIBOSMOCORE_CFLAGS) \
- $(LIBOSMOVTY_CFLAGS) \
- $(LIBOSMOGSM_CFLAGS) \
- $(LIBOSMOABIS_CFLAGS) \
- $(LIBOSMOSIGTRAN_CFLAGS) \
- $(LIBOSMORANAP_CFLAGS) \
- $(NULL)
-
-noinst_LIBRARIES = \
- libiu.a \
- $(NULL)
-
-libiu_a_SOURCES = \
- iu.c \
- iu_vty.c \
- $(NULL)
-