aboutsummaryrefslogtreecommitdiffstats
path: root/src/gprs/Makefile.am
diff options
context:
space:
mode:
authorDaniel Willmann <dwillmann@sysmocom.de>2018-06-01 07:21:20 +0200
committerHarald Welte <laforge@gnumonks.org>2018-06-15 07:33:46 +0000
commitc977afad6f270289f363ca2038104af8aaf2588d (patch)
treecdba2adcc17a20e303f3d798d683a731384d1208 /src/gprs/Makefile.am
parentaaa3e2b9aee28e6a5e5ffcb84ff24876dc4fc72a (diff)
gb_proxy: Add ctrl interface and nsvc-state, gbproxy-state commands
This patch adds a control interface to osmo-gbproxy as well as the first two commands to query the state of each NSVC and gbproxy peer. The "nsvc-state" command replies with nsei, nsvci, local state, role, remote state of all NSVCs. The "gbproxy-state" command replies with nsei, bvci, mcc, mnc, lac, rac, and state of each peer. Entries are separated by a newline '\n' character. If there are no entries an empty list is returned. This behaviour is similar to that of the subscriber-list-active-v1 command in osmo-sgsn. $ ./osmo_ctrl.py -d 127.0.0.1 -p 4263 -g nsvc-state Got message: b'GET_REPLY 23 nsvc-state 101,101,DEAD,BLOCKED,SGSN,DEAD,UNBLOCKED\n' $ ./osmo_ctrl.py -d 127.0.0.1 -p 4263 -g gbproxy-state Got message: b'GET_REPLY 4871085901306801158 gbproxy-state ' Change-Id: I82c74fd0bfcb9ba4ec3619d9fdaa0cae201b3177 Ticket: OS#3281, SYS#4235 Sponsored-by: On-Waves ehf
Diffstat (limited to 'src/gprs/Makefile.am')
-rw-r--r--src/gprs/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/gprs/Makefile.am b/src/gprs/Makefile.am
index 4c7f730a4..1cf67850c 100644
--- a/src/gprs/Makefile.am
+++ b/src/gprs/Makefile.am
@@ -44,6 +44,7 @@ osmo_gbproxy_SOURCES = \
gb_proxy.c \
gb_proxy_main.c \
gb_proxy_vty.c \
+ gb_proxy_ctrl.c \
gb_proxy_patch.c \
gb_proxy_tlli.c \
gb_proxy_peer.c \